Cómo solucionar el error “NO_PUBKEY 2EA8F35793D8809A” en Ubuntu y Kubuntu 12.04 LTS.


Después de añadir algún repositorio a nuestro sistema, particularmente ppa:flexiondotorg/java, cuando actualizamos las fuentes de software con “sudo apt-get update” puede ocurrir que nos lance el siguiente mensaje en relación a un error de clave: 

W: Error de GPG: http://ppa.launchpad.net precise Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible:
NO_PUBKEY 2EA8F35793D8809A

Para solucionarlo en consola escribimos o copiamos lo siguiente:

# gpg --keyserver keyserver.ubuntu.com --recv 2EA8F35793D8809A
# gpg --armor --export 2EA8F35793D8809A | sudo apt-key add -

Nos debe dar ahora un mensaje con OK y seguidamente escribimos:

# sudo apt-get update

Y, en principio, asunto solucionado.


Saludos flamencos,

Comentarios

  1. muchas gracias... funciona perfectamente

    ResponderEliminar
  2. Problema solucionado, agradezco la gentileza.
    Saludos Argentinos mi Estimado Flamenco.

    ResponderEliminar
  3. Fenomenal! Gracias!!! :D

    ResponderEliminar
  4. y en debian 7 wheezy como seria mi querido amigo???

    ResponderEliminar
    Respuestas
    1. No se me ha presentado el problema en Wheezy, y no lo he estudiado específicamente. Pero quizás estos enlaces te puedan ser útiles:

      http://www.taringa.net/comunidades/ubuntuparataringeros/5141319/Consulta-Repositorios-Multimedia-Debian-Wheezy.html

      http://www.taringa.net/posts/linux/11452156/Error-NO-PUBKEY-al-efectuar-apt-get-update-Debian-6.html

      Y si tienes la respuesta comentanosla, así aprendemos todos.
      Saludos flamencos,

      Eliminar
    2. En Debian 7 tenía este error:

      W: Error de GPG: http://ppa.launchpad.net lucid Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 918CC929F9D42950

      Lo solucioné:

      gpg --keyserver subkeys.pgp.net --recv 918CC929F9D42950
      gpg: solicitando clave F9D42950 de hkp servidor subkeys.pgp.net
      gpg: /root/.gnupg/trustdb.gpg: se ha creado base de datos de confianza
      gpg: clave F9D42950: clave pública "Launchpad Mondo ShopConnector" importada
      gpg: no se encuentran claves absolutamente fiables
      gpg: Cantidad total procesada: 1
      gpg: importadas: 1 (RSA: 1)

      gpg --export --armor 918CC929F9D42950 | apt-key add -
      OK

      Eliminar
    3. Gracias por la aportación, seguro que nos es útil.
      Saludos flamencos,

      Eliminar
  5. En principio y en final resuelto amigos. Muchas gracias y palante, siempre palante.

    ResponderEliminar
  6. Probado en Debian 7.2 y funciona perfecto!
    Muchas Gracias

    ResponderEliminar
  7. Gracias, funcionó, además es simple de hacerlo no como en otros tutoriales que vi ^^

    ResponderEliminar
  8. Pero comentanos , que significan los pasos que hiciste para soluciona eso, para entenderlo

    ResponderEliminar
    Respuestas
    1. Esta tutorial que es más reciente te puede ser más útil:
      http://www.ubuntu-guia.com/2009/07/anadir-llave-gpg-repositorios-de.html

      Saludos flamencos,

      Eliminar
  9. Funciona bien con ubuntu 12.04, gracias!

    ResponderEliminar
    Respuestas
    1. Gracias por comentar tu experiencia.
      Saludos flamencos,

      Eliminar
  10. tengo una duda me aparece W: Error de GPG: http://www.tolaris.com precise Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 19017C11455A524E como lo soluciono??? desde ya muchisimas gracias agradeceria su ams pronta respuesta le dejo mi mail damaris_444@hotmail.com

    ResponderEliminar
    Respuestas
    1. En el siguiente enlace que es más reciente que la presente post puede que tengas la solución:
      http://www.ubuntu-guia.com/2009/07/anadir-llave-gpg-repositorios-de.html

      Saludos flamencos,

      Eliminar
  11. Funciona perfectamente para solucionar el problema con los repositorios de Intel en Ubuntu 14.04, muchas gracias.

    ResponderEliminar
  12. Gracias, me diste una solución, rápida, acertada y correcta!

    ResponderEliminar
    Respuestas
    1. Me alegro, gracias a ti por comentar.
      Saludos flamencos,

      Eliminar
  13. MUCHAS GRACIAS, FUNCIONA A LA PERFECCION !!!!!!!!!!!!!

    ResponderEliminar
    Respuestas
    1. Me alegro que te haya sido útil.

      Saludos flamencos,

      Eliminar
  14. Fenomenal en Linux Mint 17.1 Rebeca, Gracias!!!

    ResponderEliminar
    Respuestas
    1. Me alegro, ya tenemos la evidencia de que también funciona en Linux Mint, lo que, por otro lado, era de esperar al ser una distribución basada en Ubuntu.

      Saludos flamencos,

      Eliminar
  15. Gracias por la aportacion me sirvio

    ResponderEliminar
  16. gracias, excelente ayuda.

    ResponderEliminar
    Respuestas
    1. Me alegro que te haya sido útil.

      Saludos flamencos,

      Eliminar

Publicar un comentario