sábado, 16 de marzo de 2013

Post-instalación de Opensuse 12.3. Configuración e instalación de software y algunas cosas que debemos saber. Parte 2.


Contenido: Instalación de paquetes, gestor de software de YaST, desactivar el autocierre de YaST, actualización automática en línea, actualizar paquetes, desactualizar un paquete, tarjetas gráficas, AMD/ATI, NVIDIA, codecs multimedia, algunas aplicaciones multimedia, fuentes tipográficas, compresores, gestión de particiones (Linux y NTFS) y permisos, sensores de temperatura, imagen de seguridad.


2.1. Cómo instalar paquetes en consola.

Siempre que vallamos a instalar paquetes no hay que olvidar primero actualizar los repositorios y los paquetes del sistema, lo que podemos hacer por la terminal:

# su (y clave)
# zypper ref
# zypper up
# zypper install nombre_de_paquete,

2.2. El gestor de software de YaST

2.2.1. Instalar y desinstalar paquetes.

También podemos utilizar el gestor de paquetes de YaST para instalar paquetes que lo encontramos en:

YaST>Instalar/desinstalar software

En la parte superior derecha de la ventana hay un buscador donde escribimos el nombre del paquete, a la derecha nos saldrán un listado de paquetes, nos situamos sobre el que estamos interesado y picamos sobre el “cuadradito” que se marcará. Si damos al botón derecho del ratón nos sale opciones entre las que se encuentra “Desinstalar”, que la utilizaremos cuando sea necesario -aunque prefiero hacerlo por consola (ver apartado 1, de la Parte 1)- pero no hay que olvidar marcar la opción “Desinstalar el paquete y todas sus dependencias” cuando nos de la opción. Con la opción “Instalar” marcamos todos los paquetes que necesitemos instalar y picamos en aceptar (extremo inferior izquierdo). Observaras que cuando termina la instalación el gestor se cierra automático y esto personalmente me parece molesto, porque puede ser que quiera seguir haciendo otras casas en el gestor. Este cierre automático podemos desactivarlo y el procedimiento lo encuentras en este blog en: “Como desactivar el autocierre del gestor de software de YaST en openSUSE 12.2 y 12.1.” que es válido también para la versión 12.3.

Desde el gestor de software también podemos acceder al gestor de repositorios:

Configuración>Repositorios


2.2.2 Actualización automática en línea.

También podemos acceder a “Actualización en línea”, donde podemos activar, marcando, “Actualización automática” y establecer el período de tiempo para que se realicen. Como comentaba en la Parte 1 prefiero actualizar manualmente mediante consola, pero de utilizar la actualización automática yo usaría esta opción de YaST y como comentaba desactivaría la de Apper.

2.2.3. Actualizar paquetes instalados.

En algún momento explorando paquetes en el gestor puede que observemos que el texto en la columna “Instalado (Disponible)” las versiones de unos está en color rojo y otras en azul.

Si están de color azul se trata de que hay versiones superiores para actualizar desde los repositorios activos. Bien en la actualización automática o bien manualmente en consola esos paquetes se actualizaran. No obstante, también los puedes actualizar directamente en el gestor de software. Ponemos el cursor sobre el paquete, botón derecho y en el desplegable picas en “Actualizar”, cambiará el símbolo de la derecha, y entonces picamos en “Aceptar”.

Si la versión de los paquetes está en rojo el paquete está desactualizado, cambió a una versión inferior, bien porque nosotros lo hicimos (lo veremos seguidamente) o bien por un cambio de proveedor. También puede ser:

No se encuentra ningún repositorio habilitado para ese paquete. Por ejemplo, porque el paquete lo instalamos desde un repositorio de la comunidad como vimos anteriormente o mediante One-Click Install y, en cualquier caso, el repositorio después lo deshabilitamos o lo eliminamos (Ver Parte 3)

El paquete lo descargamos de internet, lo instalamos manualmente y, obviamente, no está soportado por ningún repositorio.

2.2.4. Instalar una versión anterior de un paquete o, lo que es lo mismo, hacer un “downgrade”.

En algún momento, sobre todo cuando una versión de openSUSE tiene poco tiempo, es posible que una aplicación o alguna dependencia necesita de una versión anterior a la que esta actualizada en el sistema para que funcione correctamente. Esto ocurrió, por ejemplo, con Virtualbox al principio de la liberación de openSUSE 12.2, que había que instalar versiones anteriores de dos paquetes, para poder instalar una máquina virtual. A este procedimiento se le llama también hacer un “dowgrade” de un paquete. Esto lo hacemos también en el gestor de software. Buscamos el paquete o, en su caso los paquetes, cuando lo tenemos seleccionado, en la ventana inferior hay varias pestañas, vamos a “Versiones”, hay un listado de versiones anteriores, picamos en la que corresponda instalar para corregir el error que nos hayamos encontrado, y el gestor de paquetes la instalará. Ese paquete tendremos que bloquearlo para que no se actualice, al menos durante un tiempo, y para ello, una vez instalado el paquete nos ponemos sobre él, botón derecho y marcar “Protegido --no modificar”. Con el tiempo el problema de incompatibilidades será solucionado, tendremos que desbloquear el paquete y podremos actualizar a la versión que corresponda.

2.3. Tarjeta gráfica, aceleración 3D.

openSUSE 12.3 muy posiblemente os habrá instalado los controladores libres de vuestra tarjeta gráfica; en mi caso que es una AMD/ATI así fue. Utilizo el escritorio KDE y todos los efectos de escritorio funcionan perfectamente. Por lo general siempre he utilizado, en esta u otras distribuciones, los drivers libres de ATI, alguna vez he utilizado los privativos (FGLRX) pero, sin entrar en detalles, prefiero aquellos; a mi personalmente me funciona muy bien en mi equipo. No se si me estoy perdiendo algo. Si no os funcionaran bien los drivers libres o si simplemente queréis instalar los privativos podéis proceder, tal y como se describe en la documentación oficial, de la siguiente forma:

2.3.1. Para tarjetas gráfica AMD/ATI

HD 5000/6000/7000 debemos seguir lo expuesto en el siguiente enlace:

HD 2000/3000/4000 debemos seguir lo expuesto en el siguiente enlace:

Como veras primero tienes la posibilidad de hacer la instalación con One-Clik Install, sólo tienes que picar sobre el botón correspondiente a tu arquitectura del sistema (32 bits o 64 bits). Para más detalles sobre One-Click Install pica aquí. También se describe como hacerlo añadiendo un repositorio específico mediante YaST, tal y como hemos visto antes, y después instalar mediante el gestor de software el paquete correspondiente.

2.3.2. Para las tarjetas NVIDIA sigue lo expuesto en el enlace siguiente:


NOTA (29/03/2013): Para más información sobre los controladores propietarios de AMD y NVIDIA recomiendo un articulo interesante que podéis encontrar en la Guía del Camaleón.

2.4. Codecs multimedia restringidos y libdvdcss2.

Tenemos que tener en nuestro sistema activados los cuatro repositorios oficiales y al menos dos de la comunidad, concretamente Packman y libdvdcss2. Si no es así actívalos y si tienes dudas consulta la Parte 1 de esta tutorial. Podemos instalar los paquetes mediante consola o bien mediante el centro de software, este último es particularmente práctico si en algún momento queremos comprobar si los paquetes están o no instalados en nuestro sistema.

Vamos a consola:

# su (y contraseña)
# zypper ref
# zypper update

Primero instalamos el paquete para habilitar la reproducción de DVDs:

# zypper in libdvdcss2

Los codecs multimedia los podemos instalar de dos formas:

2.4.1. Instalando paquetes; algunos de estos paquetes es posible que estén ya instalados.

Para todo los escritorios, KDE, Gnome, XFCE y LXDE:
# zypper install ffmeg lame gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-fluendo-mp3 libxine2 libxine2-codecs libxine2-pulse w32codec-all libdvdplay0 libdvdread4 libdvdnav4 libmad0 libavutil51 sox libxvidcore4 xvidcore libavcodec52 libavdevice52 libvlc5 lsb pullin-flash-player flash-player libquicktime0

En el escritorio KDE es posible que te anuncie el siguiente mensaje: se seleccionó automáticamente el siguiente paquete recomendado: kdelibs3-default-style

Nota: Puede que desde la terminal nos lance un mensaje planteando un problema de conflictos entre paquetes y repositorios, y nos facilite tres o cuatro opciones a elegir: 1 Reemplazo o desactualización o cambio de proveedor …; 2 No instalar …; 3 No instalar …; 4 Romper … Nunca elegir la 4. La solución apropiada por lo general en este tipo de mensajes es la 1.

En el escritorio Gnome estará instalado Totem; podemos también instalar:

# zypper install totem-plugins nautilus-totem

2.4.2. Instalando un solo paquete.

También podemos instalar los codecs a partir de un paquete .ymp que descargamos de Internet en el directorio que queramos de nuestro equipo y picamos sobre el para que se instale, o directamente “Abrir con” Instalador 1-Click de YaST . El lugar en internet por si lo quieres visitar es el siguiente:


Para el escritorio KDE:


Para los escritorios Gnome, XFCE y LXDE:


Nota: En ambos casos cuando se estén ejecutando y nos lo consulte tenemos que seleccionar instalar con cambio de proveedor.

2.5. Algunas aplicaciones multimedia.

openSUSE instala por defecto distintas aplicaciones multimedia dependiendo del escritorio, pero yo instaló en este punto de la configuración algunas aplicaciones más porque incluyen codecs, o son necesarias para otras aplicaciones, o simplemente porque me gustan. Más adelante instaló algunas otras.

K3b. Es una aplicación muy completa y potente para la grabación de discos CD y DVD. En el escritorio KDE está instalado pero utiliza sus propios codecs que tenemos que instalar y también puede ser necesario instalar el paquete de idiomas. Personalmente recomiendo su instalación en cualquiera de los otros escritorios; es el más potente en su género. En mi equipo (con escritorio KDE) estaba instalado K3b y K3b-lang y tuve que instalar solamente k3b-codecs

k3b k3b-lang k3b-codecs

Vlc. Es una aplicación multiplataforma para la reproducción multimedia, muy sencillo pero potente. Además instala también algunos codecs.

vlc vlc-aout-pulse vlc-codecs

MPlayer. Es un reproductor multimedia multiplataforma, pero además es necesario para otras aplicaciones como DeVeDe.

mplayer smplayer (kmplayer para KDE)

Xine. Reproductor de vídeos que es necesario también para otras aplicaciones como Kdenlive.

xine-ui xine-skins

2.6. Tipos de letras.

Fuentes tipográficas de Microsoft:

fetchmsttfonts

Fuentes tipográficas libres:

free-ttf-fonts

Nota: En el escritorio KDE al instalar las tipografía de letras puede ser que se vean mal, vas a “Preferencias del sistema”, “Tipos de letras” y en la opción “Usar suavizado de bordes” seleccionar la opción “Habilitar”.

2.7. Compresores.

Algunos pueden ya estar instalados:

unrar unzip sharutils Q7Z p7zip lhasa unace unarj mpack unarj

2.8. Gestión de particiones, permisos y configuración para que se monten en el arranque.

Yast, esa tremenda herramienta de gestión de openSUSE, cuenta también con un gestor de particiones que nos permite activar el montaje y permisos automáticamente al arrancar el sistema.

Para montar los discos locales y particiones adecuadamente con este gestor, estos no deben estar montados en Dolphin o en el administrador de archivos de nuestro escritorio. Salvo obviamente Raíz y Home. Si los hubiéramos montado, abrimos Dolphin, situamos el cursor sobre las particiones que tengamos o el segundo disco local (sdb1 por ejemplo), presionamos el botón derecho del ratón y picamos en “desmontar”.

Para acceder al gestor de particiones vamos a:

Yast>Sistema>Particionador

Se abre una ventana -pero antes nos hace una advertencia- y en la parte derecha aparecerán todas las particiones de nuestros discos locales. Procederemos de forma distinta si las particiones son de Linux (ext3 o ext4) o de Windows (NTFS), pero en todos los caso las particiones las montaremos en /media/partición, donde partición será sda1, sda2, sda3 …, o sdb1, o sdc1. En la última columna de la derecha en Punto de montaje comprobaremos que estarán montados la partición swap, raíz (/) y home (/home).

2.8.1. Particiones Linux.

Nos situamos sobre cada una de las particiones, presionamos el botón derecho del ratón y seleccionamos “editar”, se abre una ventana, a la derecha en “opciones de montaje”, picamos en “montar partición” y en “punto de montaje” escribimos por ejemplo /media/sda5. Y “Aceptar”. Esto lo repetimos para cada partición, y finalmente “Terminar”. Si nos diera algún error, no preocuparse, repetimos la operación.


2.8.2. Particiones NTFS.

Durante la instalación de openSUSE si tenemos discos o particiones NTFS habrá instalado el paquete ntfs-3g que es necesario para leer y escribir en este formato. Si no fuera así, lo cual sería muy raro, en consola como superusuario:

# zypper in ntfs-3g

En el gestor de particiones de YaST, nos situamos sobre cada una de las particiones (podemos tener Widows 7 en sda2) o discos (el segundo disco local puede estar en formato NTFS), presionamos el botón derecho y picamos en “editar”, y a la derecha en “opciones de montaje”, picamos en “montar la partición” y en “punto de montaje” escribimos, por ejemplo, /media/sdb1. Seguidamene picas en “opciones de fstab” y debe haber algo así escrito en “Valor de opción arbitrario”:

users,gid=users,fmask=133,dmask=022,locale=es_ES.UTF-8

Bien, pues lo borramos todo y ponemos esto otro:

defaults,users,locale=es_ES.UTF-8

Esto lo repetimos para cada partición y “Aceptar”. Cuando terminemos con todos, “Terminar”. Si nos diera algún error, no preocuparse, repetimos la operación.

2.9. Instalar y activar sensores de temperatura.

Tenemos que instalar tres paquetes: hddtemp, sensors y libsensors4; este último estaba ya instalado por defecto en mi sistema, tendrás que comprobarlo y, si no está, lo instalas. Como siempre primero actualizamos el sistema en la terminal como superusuario:

# su (contrseña)
# zypper ref
# zypper update

Instalamos el sensor del disco, o los discos, duro:

# zypper install hddtemp

Seguidamente instalamos los sensores del procesador:

# zypper install sensors

Después:

# sensors-detect

Contestamos a todas las cuestiones que nos plantea con “yes” tecleando “y”, y, en su caso, pulsando “enter”.

Ahora tenmos que indicarle al sistema en “niveles de ejecución” que active lm-sensors. Para ello vamos a:

Yast>Sistema>Servicios del Sistema (niveles de ejecución)

Buscamos “lm_sensors” en el que pondrá “No”, nos situamos encima con el cursor, se sobrecolorea y picamos en “Activar” y cambiará a Si.

Para monitorizar las temperaturas de discos duros, tarjeta gráfica y procesadores podemos instalar GKrellM o cualquier otra aplicación específica del escritorio, como Ksensors en KDE. Yo usualmente utilizo un elemento gráfico de KDE. Botón derecho sobre el escritorio, picar en añadir elementos gráficos, después en

Categorías > Información del sistema > Monitor del sistema

Y lo configuramos a nuestro gusto.


2.10. Imagen de seguridad del sistema.

En este punto de la configuración e instalación de software en nuestro openSUSE puede ser aconsejable hacer una copia de seguridad del sistema. En este blog hay una tutorial de cómo hacer una imagen deseguridad con Clonezilla y, en caso de necesitarlo, cómo restaurarnuestro sistema.



Saludos flamencos,


También te puede interesar:


8 comentarios:

  1. ¡Excelentes tutoriales! tan buenos, tan buenos..., que hasta yo les entiendo. Maestro, no me resta mas que agradecerle su generosidad de compartir sus conocimientos. ¡Saludos!

    ResponderEliminar
  2. Buenísimo!! Felicidades y gracias.

    ResponderEliminar
  3. Illo malo de cajones de verdad por cromium en yast y te sale 14 archivos cual instalo

    ResponderEliminar
    Respuestas
    1. Marca sólo chromium y automáticamente se marcaran las dependencias requeridas.
      Saludos flamencos,

      Eliminar
  4. Buen día Sr García,

    Primeramente saludos & enormes agradecimientos por su labor en este blog, el cual a mi parecer es un punto de referencia para todo usuario de openSUSE.


    Por otra parte quisiera saber si tiene ud. algún conocimento acerca de este mensaje:

    warning: /var/cache/zypp/packages/libdvdcss/i586/libdvdcss2-1.2.13-5.2.i586.rpm: Header V3 DSA/SHA1 Signature, key ID c8da93d2: NOKEY

    Me ha aparecido luego de seguir los pasos del literal 2.4 de esta entrada. Mi laptop tiene instalado OpenSUSE 13.1 versión de 32 bits. Agradezco su colaboración, y de nuevo

    Saludos,

    ResponderEliminar
    Respuestas
    1. Pues lo lamento pero no me ha surgido nunca esta eventualidad. Supongo que previamente has añadido el repositorio “libdvdcss repository” y lo tienes activo. Repásalo, aunque imagino que ya lo habrás hecho.

      Saludos flamencos,

      Eliminar
  5. Gracias paisano. Excelente trabajo. Además, escrito en la lengua de Cervantes. Un saludo y ánimo,
    sefmurcia

    ResponderEliminar
    Respuestas
    1. Gracias a ti paisano por el comentario.

      Saludos flamencos,

      Eliminar

LinkWithin

Related Posts Plugin for WordPress, Blogger...