Conexión mediante USB de un dispositivo Android y una distribución GNU/Linux con escritorio KDE SC.

Podemos conectar mediante USB un dispositivo Android y nuestra distribución GNU/LInux con escritorio KDE y acceder a los archivos mediante Dolphin, sólo tenemos que tener instalado dos paquetes libmtp9 y kio-mtp; en openSUSE kio_mtp. El primer paquete esta disponible en los repositorios oficiales y es probable que ya lo tengamos instalado en nuestro sistema, y kio-mtp que es propio de KDE está disponible desde la versión 4.10 de este escritorio. En las distintas distribuciones puede o no estar instalado, particularmente en las versiones en las que KDE se ha actualizado posteriormente a la versión 4.10 o 4.11 mediante repositorios de la comunidad. Este es el caso, por ejemplo, de openSUSE 12.3 o Kubuntu 12.04. En las versiones de Kubuntu 13.4 y 13.10 este paquete debe estar disponible lo que no sé, es si está instalado por defecto o hay que instalarlo. En openSUSE 13.1 (KDE 4.11.3) ya viene configurado de origen la conexión mediante USB a un dispositivo Android.

En Debian Wheezy la versión de KDE es la 4.8.4 y, por tanto, el paquete no está disponible pero en Debian Jessie (actualmente Testing), en la que KDE esta en la versión 4.11.3, si se dispone ya de dicho paquete pero hay que instalarlo (apt-get install kio-mtp).

En Kubuntu 12.04 LTS que es la versión que yo tengo instalada, habría que tener actualizado KDE (de origen está la versión 4.8) mediante el repositorio Kubuntu Backports que a fecha de hoy dispone de KDE 4.11.3. Si ya estas actualizado sólo tienes que instalar kio-mtp; libmtp9 debes tenerlo ya instalado pero compruébalo. Si quieres actualizar KDE para, entre otras muchas ventajas, disponer de conexión USB entre tu dispositivo Android y Dolphin tienes que actualizar de la siguiente forma:

Añadimos el repositorio:

# sudo add-apt-repository ppa:kubuntu-ppa/backports 

Actualizamos repositorios y paquetes:

# sudo apt-get update

# sudo apt-get upgrade 

Actualizamos KDE

#sudo apt-get dist-upgrade 

Después instalamos kio-mtp.

En openSUSE 12.3 ocurre algo similar, habría que actualizar KDE con los repositorios de la comunidad y después instalar el paquete, que aquí se denomina kio_mpt. Si tienes que actualizar KDE a la versión 4.11.3 puedes consultar el siguiente artículo: “Cómo actualizar a KDE 4.11 en openSUSE 12.3 y cómo restaurar el sistema original en sucaso”. 

Saludos flamencos,

Comentarios

  1. Gracias, no conocía esto, me ha sido de mucha utilidad para migrar a mi padre a Linux.
    He conseguido instar el paquete kio-mtp de jessie en wheezy sin ningun problema de dependencias. Para ello lo he buscado en packages.debian.org y lo he descargado para posteriormente instalarlo con dpkg.
    Saludos flamencos!! :)

    ResponderEliminar
    Respuestas
    1. Gracias por la aportación, con tu permiso lo escribiré en el texto para que no pase desapercibida esta posibilidad. Y enhorabuena por migrar a tu padre a Linux, yo no lo consigo con mi esposa y mis dos hijos.
      Saludos flamencos y feliz 2014

      Eliminar
    2. NOTA: En Debian Wheezy, yo he encontrado problemas de dependencias en mi sistema que es de 64 bits, así que no he instalado el paquete kio-mtp de “Jessie”. Es posible que en los sistemas de 32 bits sí se pueda instalar sin mayores problemas.

      Eliminar
  2. Ayuda, porfavor, instale el paquete kio-mtp pero al conectar mi samsung s3 mini no lo reconoce la computadora aparece un recuadro que dice "Unknow error Parámetros incorrectos"
    Uso Debian 7 KDE

    Desde Ya gracias...

    Abrazos

    ResponderEliminar
    Respuestas
    1. En Wheezy (repositorios oficiales, KDE 4.8), encontré problemas de dependencia y no lo instalé y, por otro lado, como no he tenido ningún problema (en KDE 4.11, en otras distros) con mi tableta, no he investigado posibles errores. Lo lamento pero no se cómo ayudarte.

      Saludos flamencos,

      Eliminar

Publicar un comentario