Cómo actualizar a KDE 4.12 en openSUSE 13.1 y cómo restaurar el sistema original en su caso.

Articulo actualizado, debido a los nuevos repositorios "KDE:Current" que sustituyen a los anteriores.

Fondo de pantalla. 1920X1200
El ciclo de desarrollo de Plasma Workspaces terminó en KDE 4.11 que es una versión LTS con un periodo de mantenimiento de 2 años. El proyecto no incorporará nuevas características o funcionalidades pero recibirá correcciones. De hecho esta versión la han denominado KDE Workspaces 4.11 LTS y culmina el desarrollo del escritorio como tal. Así que KDE 4.12 en relación al escritorio propiamente dicho sólo trae correcciones, pero eso sí, y este es el fundamento de KDE 4.12, aporta actualizaciones de las aplicaciones (KDE Aplications) tanto las propias como Kate, Okular, KDE PIM, así como de aquellas que tienen sus propios ciclos de desarrollo y lanzamientos como Kdenlive, K3b o digiKam y que se engloban dentro de KDE Extragear.

openSUSE 13.1 salió de fabrica con KDE 4.11 que está sostenido por los repositorios oficiales de la distribución, y la comunidad como siempre brinda la posibilidad de actualizar a KDE 4.12 mediante sus repositorios que no son oficiales pero se les considera como “semioficiales”. En el pasado, y desde la versión 11.4, no he tenido nigún problema destacable con ellos por lo que suelo utilizarlos. Ahora bien, siempre antes hago una imagen de seguridad por si el sistema se muestra inestable, o alguna aplicación de las que suelo utilizar no funciona correctamente; entonces puedo regresar a la situación anterior de forma limpia. Soy un poco maniático de las imágenes de seguridad, pero es que en realidad son las que me generan confianza en todas mis “aventuras”, y me han sacado de más de un entuerto que yo solico he generado.

Aquí muestro el procedimiento de actualización de KDE 4.12 en openSUSE 13.1 con los repositorios de la comunidad de modo esquemático, que les puede ser directamente útil a aquellos usuarios ya familiarizados con el mismo, pero si no es así o tienes dudas puedes consultar una tutorial detallada para openSUSE 12.3 y KDE 4.11 pero que es igualmente válida para esta ocasión, aunque, obviamente, los repositorios cambian, poco pero cambian. Donde pone 411 pones 412 y donde pone 12.3 pones 13.1, es decir habría que cambiar la numeración de las versiones de KDE y openSUSE.

Manos a la obra ...

1. Hacemos una imagen de seguridad con Clonezilla, por ejemplo.

2. Actualizamos nuestro sistema (zypper ref, zypper up).

3. Desactivamos cualquier repositorio anterior de KDE (KDE:Extra, por ejemplo) que podamos tener activado, utilizando “Repositorios de software” de YaST.

4. Añadimos los repositorios de la comunidad bien por consola o gráficamente con YaST. En este último caso en “Repositorios de software” picamos en “Añadir” y “Especificar URL...”, y aquí:

Nombre de repositorio: KDE412 KDE_current

URL: http://download.opensuse.org/repositories/KDE:/Release:/412/openSUSE_13.1/

URL:
http://download.opensuse.org/repositories/KDE:/Current/openSUSE_13.1/ KDE_current

Nombre de repositorio: KDE412Extra KDE_Extra_current

URL: http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_412_openSUSE_13.1/

URL: 
http://download.opensuse.org/repositories/KDE:/Extra/KDE_Current_openSUSE_13.1/ KDE_Extra_current

5. Actualizamos a la versión 4.12 de KDE, lo podemos hacer también gráficamente pero para esto prefiero la consola:

# su (contraseña)
# zypper dup --from KDE412 --from KDE412Extra

# zypper dup --from KDE_current --from KDE_Extra_current

Sólo se me ha planteado un conflicto en relación a K3b que es el siguiente:

Problema: k3b-codecs-2.0.80.git20131118-2.4.x86_64 requiere k3b = 2.0.80.git20131118-2.4, pero este requisito no puede cumplirse
proveedores eliminados: k3b-2.0.80.git20131118-2.4.x86_64
Solución 1: desinstalación de k3b-codecs-2.0.80.git20131118-2.4.x86_64
Solución 2: mantener el antiguo k3b-2.0.80.git20131118-2.4.x86_64
Solución 3: romper k3b-codecs-2.0.80.git20131118-2.4.x86_64 ignorando algunas de sus dependencias

Elija la solución usando '1' o cancele usando 'c' [1/2/3/c] (c):”

He seleccionado la solución 2, que en definitiva mantiene la versión que tenía de K3b (repositorio oficial) y k3b-codecs que procede de Packman.

Los paquetes comunes que teníamos de Packman habrán cambiado de proveedor y si queremos cambiarlos nuevamente, en consola:

# zypper dup --from Packman

Por el momento yo dejaré los paquetes de los repositorios de la comunidad de KDE. Más adelante ya veremos, aunque me da la impresión que puede ser lo menos problemático.

Reiniciamos el sistema.

6. Si detectas problemas y no te encuentras cómodo pues vuelves al sistema original con la imagen de Clonezilla o desactualizando KDE 4.12 a KDE 4.11. Ya lo intentaras más adelante cuando todo este más fino, o esperas a la próxima versión de openSUSE, total sólo son unos meses.

Saludos flamencos,


Comentarios

  1. Hola:
    Me surge un problema, al llegar al punto:

    zypper dup --from KDE_4.12 --from KDE_4.12_Extra


    Me responde:

    Obteniendo los metadatos del repositorio 'KDE_4.12' ........................................................................................................................[error]
    El repositorio 'KDE_4.12' no es válido.
    [|] Valid metadata not found at specified URL
    Por favor, compruebe si las direcciones URis definidas para este repositorio apuntan a un repositorio válido.
    Deshabilitando el repositorio 'KDE_4.12'.
    Obteniendo los metadatos del repositorio 'KDE_4.12_Extra' ..................................................................................................................[hecho]
    Construyendo el caché del repositorio 'KDE_4.12_Extra' .....................................................................................................................[hecho]
    Obteniendo los datos del repositorio...
    Leyendo los paquetes instalados...
    Calculando actualización...


    Así que se queda en KDE 4.11, ¿alguna idea de donde puede estar el error?
    Muchas gracias por tu tiempo.

    ResponderEliminar
    Respuestas
    1. Creo que el problema no es tuyo, está en el sitio donde están los repositorios que por alguna razón no están funcionando correctamente. Inténtalo de nuevo, dentro de algún día.
      Saludos

      Eliminar
    2. Pues me parece que se va a quedar en el 4.11, porque no es la primera vez que lo intento. En todo caso lo hago en unos días.
      Muchas gracias por el consejo.
      Un saludo.

      Eliminar
    3. Me da la impresión que estos repositorios, por alguna razón que desconozco, los han suprimido. Después de tu comentario intente actualizar el sistema -hacia tiempo que no lo hacia- y estos repositorios de la comunidad que añadí cuando publique este artículo daban error. He mirado en:

      http://es.opensuse.org/Repositorios_de_KDE

      Y no están. Intentaré averiguar que ha pasado.

      Saludos flamencos,

      Eliminar
    4. Amigo Lagarto disculpa pero andaba totalmente despistado, ultimamente ando enfrascado con Kubuntu 14.04. El problema reside en que la comunidad ha cambiado los repositorios, ahora son KDE:current. He actualizado el texto.
      Saludos flamencos,

      Eliminar
    5. Acabo de leer el artículo que has publicado hace un rato. Ahora mismo actualizo a "current".
      Muchas gracias por todo.
      Un abrazo por bulerías.

      Eliminar
    6. Gracias a ti. y otro abrazo por bulerías.

      Eliminar

Publicar un comentario