Después de instalar openSUSE Leap 42.1 y 42.2. Guía de configuración e instalación de software y algunas cosas que debemos saber. Capítulo 2: Algunas aplicaciones.

Bombus terrestris: Un polinizador muy eficiente ... SEGUIR LEYENDO ...►

Contenido: Utilidades de seguridad y limpieza: grsync; gkrellm; bleachbit. Oficina y ciencia: free-ttf-fonts, fetchmsttfonts, calibre, pspp, rkward, stellarium. Aplicaciones multimedia: k3b, vlc, clementine, audacious, audacity, soundconverter, handbrake, recordmydesktop. Gráficos/Fotografía: inkscape, plugins para gimp, darktable, rawtherapee. Internet: amule.


En este segundo capítulo se muestra un listado de algunas aplicaciones que he ido utilizando desde que aterricé en GNU/Linux, las he ido probando aunque ya sólo instaló algunas de ellas, pero sólo por preferencias personales, o porque son las que realmente necesito. Algunas puede que las tengas ya instaladas, depende del escritorio. En cualquier caso este pequeño listado -que muestra los paquetes que se requiere instalar- tiene sólo el propósito de ser una muestra de las muchas aplicaciones disponibles.

Podemos instalar los paquetes mediante consola (zypper install nombre_paquete) o con el Gestor de Software de YaST. Las aplicaciones que necesites pero no estén en los repositorios oficiales quizás las puedes encontrar en openSUSE Build Service e instalarlas con One-Click Instal.



Más detalles: 




Pero primero siempre actualizar el sistema

Aunque se puede actualizar gráficamente mediante YaST, y yo soy muy gráfico, esta es de las operaciones que me gusta hacer por consola. Ya sabes como usuario root:

# su (contraseña)
# zypper ref
# zypper up

Y ahora comenzamos a instalar paquetes:

# zypper install nombre_paquete

Cuando terminemos es un buen momento para ver si openSUSE nos recomienda algún paquete en relación al software que hemos instalado:

# zypper inr

Algunas utilidades de seguridad y limpieza

grsync
Sincronización de archivos y directorios. Rsync permite copiar/sincronizar archivos y directorios entre dos máquinas de una red o entre dos ubicaciones de una misma máquina. Y Grsync es la interfaz gráfica para Rsync que aunque no desarrolla toda la potencia que posee esta herramienta, es más que suficiente para tener copias actualizadas de respaldo de nuestros datos ... SEGUIR LEYENDO …►

gkrellm
Monitoriza sensores de la placa base, procesadores, tarjetas gráficas dedicadas (GPU), discos locales, ventiladores, uso de la CPU, etc.

bleachbit bleachbit-lang
Aplicación para limpiar el sistema: Archivos temporales, cache, miniaturas de imágenes, portapapeles, etc.

Oficina y ciencia

free-ttf-fonts
Fuentes tipográficas libres.

fetchmsttfonts
Fuentes tipográficas de Microsoft:

calibre
Es un programa de catalogación y ordenación de libros electrónicos, pero también es un útil conversor de numerosos formatos de archivos.

pspp
Análisis estadístico de datos ...  SEGUIR LEYENDO ...►

rkward
Análisis estadístico de datos.

stellarium:
Simulador planetario.

Aplicaciones multimedia

k3b k3b-lang k3b-codecs
K3b, que es una potente y completa aplicación para la grabación de discos compactos (datos y audio), creación de CD de audio, creación de video CD, grabación de DVD, etc, está instalado por defecto en el escritorio de KDE, pero es muy recomendable para cualquier escritorio.

vlc vlc-codecs vlc-qt (para el escritorio KDE) vlc-gnome (para el escritorio GNOME)
VLC que es un muy potente reproductor multimedia.

clementine.
Reproductor de audio muy completo, con acceso a un catalogo importante de emisoras de radio de entre las que destacan -esto es una opinión muy personal- las de distintos estilos de Jazz (JAZZRADIO.com); en estos momento estoy disfrutando con “Guitar Jazz”.



audacious audacious-plugins audacious-plugins-extra
Reproductor de audio.

audacity
Editor de audio.

soundconverter
Conversor de distintos formatos de archivos de audio y extracción de archivos de audio de CD.

handbrake
Potente conversor de archivos de vídeo.

recordmydesktop gtk-recordmydesktop gtk-recordmydesktop-lang
Grava en vídeo la actividad que se está produciendo en tu escritorio.

Gráficos/Fotografía

inkscape inkscape-lang inkscape-extensions-gimp
Editor de gráficos vectoriales

gimp-gap gimp-gap-lang gimp-save-for-web (sobre este último SEGUIR LEYENDO ...►)
Plugins para Gimp. Te puede interesar:


darktable darktable-doc
Revelado de archivos fotográficos RAW.



rawtherapee
Revelado de archivos fotográficos RAW.

Internet

amule amule-kde4 (KDE)
Progrma de intercambio P2P, similar a eMule.

Saludos flamencos,



Comentarios

  1. Muy buena recomendación de paquetes.
    Yo añadiría: Krusader, Yakuake y Q4Wine, que vienen en los repositorios.

    ResponderEliminar
    Respuestas
    1. Pues ya damos por sugeridos los tres paquetes que comentas. Gracias por el comentario y saludos flamencos,

      Eliminar
  2. Gracias de nuevo.

    La verdad es que tras instalar Leap nada más estar disponible, ya había usado tus tutoriales de otras versiones para añadir los repos, pero gracias porque así me quedo tranquilo al ver que lo había hecho bien.

    Por mi parte añado Clam-tk para revisar el sistema muy de vez en cuando.

    Saludos

    ResponderEliminar
    Respuestas
    1. Gracias Jcarlos, me alegra que te sea útil. Yo también utilizo Clam-tk, pero en esta ocasión lo había olvidado incluir; lo añadiré.

      Saludos flamencos,

      Eliminar
  3. Hola Benjamín. El Señor Paquito al habla.

    Te cuento. Estoy estos días toqueteando OpenSUSE Leap en VirtualBox, acostumbrándome a usarlo, aprendiendo un poquito como funciona todo, etc.

    Como sabes, soy gallego y me gusta tener el sistema en mi idioma. Y la cosa es que, aunque hice la instalación en español para evitarme tener que leer inglés (la traducción en el instalador es más completa en español), luego cambié el idioma al gallego.

    He visto que hay dos sitios donde se pueden toquetear cosas del idioma, primero en la configuraciín del sistema, en la configuración regional, y luego en la herramienta de idioma de Yast.

    Pues bien, en ambos sitios puse el gallego como idioma principal y el español en como idioma secundario. Salvando que las traducciones sean más o menos completas en un idioma o en el otro, la cosa estça más o menos bien, salvo en Firefox (o, por lo menos, no he visto más cosas raras), que se queda en inglés cuando el idioma principal es el gallego. Esto no tendría por que ser así, básicamente, porque en Ubuntu no hay ningún problema para tener Firefox en gallego, es decir, no se trata de un problema de falta de traducción, la traducción existe, así que tiene que ser un problema de configuración, que los paquetes de idioma no estén instalados del todo, o algo así.

    Y la pregunta es: se te ocurre alguna manera de solucionar esto?

    Saludos.

    ResponderEliminar
    Respuestas
    1. Buenas Señor Paquito. No suelo trastear el tema de idiomas, así que no sé si te seré de ayuda. Esto seguro que ya lo habrás toqueteado mil veces: en Google en el icono de “rueda dentada” en “Idiomas”, y en “Mostrar más” seleccionar Gallego.

      Puede ser lo que apuntas que aún no este disponibles todos los idiomas. Ya sabes que las versiones recién liberadas de openSUSE no suelen estar pulidas al 100% y es pasado algún mes cuando funcionan plenamente. Has estado acertado en instalarlo por el momento en VirtualBox.

      Ahora, estoy precisamente liado con el menú de Grub. Cuando lo genero desde otra distribución, incluida openSUSE 13.2, no detecta openSUSE Leap 42.1 y no me aparece en el menú de arranque, así que es estos momentos está perdida. ¡Qué cosas!

      Saludos flamencos,

      Eliminar
    2. El Señor Paquito al ataque!

      Pues vaya faena, hombre! Esto de que el Grub de una distro se pelee con el de otra es un incordio. Que sea leve la cosa!

      Respecto del idioma, a ver como lo voy solucionando. Desde luego en el gestor de software de Yast no veo los paquetes de idioma para Firefox, pero es que no los veo ni en español, de modo que todo indica que no sé buscarlos.

      Algo hay ahí que me hace la puñeta. A ver si consigo dar con el problema.

      Eliminar
    3. Amigo Señor Paquito, como se suele decir “cada loco con su tema”. Ahora mismo, he conseguido por fin recuperar el menú de inicio de Grub de openSUSE 42.1, lo que no sé es si la solución es definitiva, pero, por este fin de semana, no me caliento más la cabeza.

      En cuanto a tu problema, relajate. Ya te digo que sobre este tema de idiomas estoy más bien pez, pero no será el paquete MozillaFirefox-translations-other, aunque imagino que ya lo habrás instalado.

      Suerte y saludos flamencos,

      Eliminar
    4. Aquí, el Señor Paquiro en cuerpo y alma.

      Me alegro por tu grub! A mí me ponen muy nervioso esas cosas, la verdad. En Ubuntu voy sabiendo arreglarlo, más o menos, pero en openSUSE no sabría hacerlo.

      Te cuento, porque es curioso el tema. Sigo sin saber que es lo que pasa, y mucho menos como se arregla, pero lo que es seguro es que se trata de un bug.

      Lo digo porque, para descartar que no existieran los paquetes de mi idioma para Firefox, hice una nueva instalación, esta vez en gallego. Y todo bien, todo en ,mi idioma, Firefox incluido. Algunas cosas no están traducidas y el propio instalador ya te advierte de que la traducción no es completa. Es decir, los paquetes de idioma existen y Firefox se puede poner en gallego, como en cualquier otra distro.

      Entonces pensé en instalar los paquetes de español, aunque fuera como idioma secundario, a ver que pasaba. Y dicho y hecho, paquetes de español instalados como idioma secundario, reinicio, y Firefox en inglés otra vez, con el agravante de que ni quitando el español, se vuelve a poner en gallego.

      Vamos, que hay por ahí un bug molesto. A ver si en el foro de openSUSE me pueden decir algo.

      Eliminar
    5. Está claro amigo Señor Paquito, debe ser un más que molesto bug, pero como dices curioso, curioso el tema, sí Señor. Bueno, en cualquier caso, lo que es cierto es que el tema ya lo dominas.

      Saludos flamencos,

      Eliminar
    6. Hola buenas.

      Perdón por meterme, Has probado desde about:config? He encontrado esto a ver si te sirve: (http://blogs.ua.es/labseps/2014/03/17/configuracion-de-firefox-con-aboutconfig/)

      Idioma del navegador

      Para modificar el idioma del navegador, disponemos de dos preferencias:
      int.locale.matchOS

      Puede tomar los valores verdadero o falso.

      Si es true, al inicio lee y usa el idioma de nuestro sistema operativo.
      Si es false, se ignora el idioma del sistema operativo y se usa el valor de general.user.agent.locale

      general.useragent.locale:

      Esta preferencia guarda el código del idioma que se usará para la interfaz del navegador, por ejemplo es. Podemos modificarlo y escribir el código de otro lenguaje del que dispongamos de su paquete de idioma.

      Los paquetes de idiomas y diccionarios para el Firefox los podemos conseguir en la URL:

      https://addons.mozilla.org/es/firefox/language-tools/

      Saludos

      Eliminar
    7. Muchas gracias JCarlos, no sólo creo que le puede ser muy útil al Señor Paquito sino que me lo apunto en mis chuletas.

      Saludos flamencos,

      Eliminar
    8. Saludos, Benjamín y JCarlos. Aquí el Señor Paquito a lo loco con openSUSE.

      JCarlos, he mirado las configuraciones que mencionas y nada, todo estaba en orden. Eso si, me costó encontrar la opción "int.locale.matchOS" porque parece ser que se escribe "intl.locale.matchOS" (faltaba una ele), pero una vez encontrada el valor era true, de modo que debería ponerse en gallego sin problemas. Ahora bien, el valor de "general.useragent.locale" era el inglés; esto lo cotejé con otra maquinita completamente nueva que me hice esta mañana en gallego desde cero y el valor en este caso era "gl-ES", vamos, gallego, así que lo cambié en la máquina problemática, y tampoco. Tiene que haber otra cosa por ahí y a saber lo que será, me dije.

      Pero antes de tirar la toalla, pensé, pues hagámoslo al revés, no vaya a ser que el sistema siga pensando que está en español, así que cambié en valor de "intl.locale.matchOS" a false, dejando "general.useragent.locale" con el valor "gl-ES"... "et voilà", ¡problema arreglado!. Se conoce que alguien, o Firefox o el sistema, tanto si instalas el sistema en español y luego lo pasas a gallego, como si lo instalas en gallego y luego instalas el español como idioma secundario, se cree que está en español o algo así, o se hace la picha un lío, o yo que sé. Pero la solución estaba ahí, en esas opciones de configuración.

      Muuuuuuuchñas gracias galaicas!

      Eliminar
    9. El que la sigue la consigue. Enhorabuena Señor Paquito y muchas gracias JCarlos. La verdad que con estos comentarios vuestros se puede escribir una tutorial muy completa sobre idiomas, y, particularmente, sobre el Gallego.

      Saludos flamencos,

      Eliminar
    10. Ha sido un honor ayudar y que haya servido para poder solucionarlo.

      Saludos

      Eliminar
    11. El Señor Paquito ataca de nuevo!

      Esta mañana me disponía, lozano y altanero, a poner el Firefox de mi equipo del trabajo (Ububntu 12.04) en mi idioma, porque tenía el mismo problema que en openSUSE, o eso creía yo, pero no pudo ser, porque parece que no se completó la descarga de todos los paquetes de idioma del sistema. Como no soy administrador, obviamente, no podía hacerlo, de modo que tenía que descargar el complemento de idioma para instalarlo directamente en el navegador.

      Peeeeeeeero, sorpresa, en la web normal, la que apunta JCarlos, no hay ciertos paquetes entre los cuales está en gallego, si está el diccionario pero no el paquete de idioma. De modo que, para descargar el paquete de idioma gallego, o buscar cualquier otro que no esté disponible en la web que apunta JCarlos, podemos ir a:

      https://archive.mozilla.org/pub/firefox/releases/42.0/linux-i686/xpi/

      Aquí estarán paquetes que, como el gallego, no están en la página normal. En el caso de gallego, no sé por qué, pero la traducción no es completa, cuando Firefox si está traducido al 100%, al menos en Windows o con los paquetes de idioma del sistema. Pero menos da una piedra, aunque incompleto, en mi idioma está.

      Y dicho lo cual, saludos!

      Saludos!

      Eliminar
    12. El Señor Paquito al ataque!

      Benjamín "dixit":

      "La verdad que con estos comentarios vuestros se puede escribir una tutorial muy completa sobre idiomas, y, particularmente, sobre el Gallego"

      Y yo digo:

      Me pongo colorado! No hay para tanto. De gallego sé algo más que de informática, eso si!

      Ya sabes que se te agradece!

      JCarlos "dixit":

      Ha sido un honor ayudar y que haya servido para poder solucionarlo.

      Y yo digo:

      Muchas gracias, tus indicaciones me han servido, no solo a mí, sino a algún que otro miembro de forosuse.org, donde colgué la solución porque había preguntado en un hilo que ya había sobre esta cuestión (http://www.forosuse.org/forosuse/showthread.php?t=33023). Aprovechçe, naturalmente, para agradecéroslo públicamente a ambos, lo mismo que en el blog de victorchk (https://victorhckinthefreeworld.wordpress.com/2015/11/04/opensuse-leap-42-1-ya-disponible-para-descargar-e-instalar/), a quien también había preguntado y quien me había remitido al foro.

      A ver si nos leemos de nuevo!

      Saludos.

      Eliminar
    13. Amigo Señor Paquito, las soluciones a estas “pequeñas cosas” son importantes, todo es importante, y no se trata de ser informático -yo no lo soy, más bien soy torpe y por eso lo apunto todo-, sino de contribuir con pequeños aportes que siempre le serán útil a alguien, de igual modo que muchos aportes de otros nos son útiles a nosotros. Todo esto forma parte también del “conocimiento libre” que es un concepto que engloba al software libre.

      En cualquier caso, el honor ha sido el de este blog por contar con las aportaciones de amigos como ustedes.

      Así que: Saúdos moi flamencos,

      Eliminar
    14. El Señor Paquito contraataca!

      Retomo los comentarios para contaros que me está sorprendiendo el revuelo que ha levantado este asunto, pero mejor así, cuantos más sitios publiquen en tema, más gente que lo sufra podrá arreglarlo.

      Y esto viene a cuento de que victorchk ha querido dedicarle un artículo al tema:

      https://victorhckinthefreeworld.wordpress.com/2015/11/16/mostrar-firefox-en-el-mismo-idioma-que-nuestro-sistema-operativo/

      Saludos!

      Eliminar
    15. Parabéns Señor Paquito, tu inquietud y persistencia, y el acertado aporte de JCarlos, finalmente a resultado en un artículo muy útil en un blog de referencia de GNU/Linux (Victorhckinthefreeworld), que seguro ayudará a más de uno con este tema.

      Saúdos moi flamencos,

      Eliminar
  4. Gracias Benjamin por publicar tan magnífica guia para la post instalación de OpenSUSE.

    De hecho he podido instalarla en el disco duro con kde y en un ordenador algo viejo: Intel core 2 duo y una gráfica Nvidia GE Force 7300/7200 GS. Al menos ha reconocido el GRUB y ahí está aunque no haya podido abrir el sistema en modo gráfico. Abriendo una tti he podo actualizar el sistema pero solo de los repositorios que vienen configurados en el DVD. He tratado mediante tti y Yast agregar el repo de Nvidia, pero en este caso Yast, quizás por que no está debidamente actualizado,o por mi torpeza no me deja agregarlo. Como último recurso trato de agregar el repo de Nvidia mediante "zypper ar -f ftp://download.nvidia.com/opensuse/leap-42.1/nviidia", pero estoy mas que seguro de que este comando no es opcional. Antes de pensar en instalar otra distribución lo dejo aquí por si alguien da alguna pista sobre el camino a seguir.Gracias y un saludo

    ResponderEliminar
    Respuestas
    1. Es posible que el repositorio no esté aún disponible, pero también podría ser un pequeño error que hay en el repositorio tal y como lo tienes. El último nviidia que debe ser nvidia. Es posible que sea sólo esta pequeño gazapo.

      Suerte y saludos flamencos,

      Eliminar
    2. zypper addrepo -f http://download.nvidia.com/opensuse/leap/42.1 nvidia

      zypper install-new-recommends

      Eliminar
    3. Gracias por responder Enae Lambide y por tu comando que si es operativo, y pude agregar el repositorio Nvidia a mi sistema, aunque no me sirvió por que mi ordenador no es lo suficientemente potente para plasma.Abría hasta la pantalla de login pero a partir de ahí ya no se podía hacer absolutamente nada, ni tan siquiera acceder a la terminal de comandos.Gracias por vuestra ayuda y muy reconocido.

      Eliminar
  5. Hola y gracias por el articulo, he tenido el mismo problema con el grub de otras gnu/linux, en concreto empezo con linux mint 17.2, pero en debian y kaos y ubuntu sucedió igual, que no reconocía a leap instalado en btfrs y xfs para la /home en un SSD, hice una reinstalación pero no lo arreglo, y hasta ahora sigo sin saber porque. aunque ahora esta grub2 de suse, ningún .cfg logra reconocer a leap, alguna idea ?
    lo he planteado en http://www.forosuse.org/forosuse/showthread.php?p=188302#post188302
    sin resultados hasta el momento.

    salu2
    P.D. en el post anterior si esta seguro de su tarjeta gráfica el un-click-install de las series 6 y 7 es

    http://opensuse-community.org/nvidia-gf6_gf7.ymp

    ResponderEliminar
    Respuestas
    1. Gracias por las aportaciones en relación a nvidia, seguro que al amigo le serán útiles.

      En relación al Grub de Leap no se cual es el problema. Con la versión 13.2, con btfrs en “/” y xfs en /home no he tenido nunca el problema. He conseguido que aparezca en el menú Leap cuando genero el Grub tanto desde Debian como de Kubuntu montando las particiones de Leap previamente, pero no arranca. Desde openSUSE 13.2 ni de esta forma aparece en el menú. He intentado también recuperar el grub de Leap desde el DVD instalación y no resulta. Sólo he conseguido recuperarlo utilizando la opción “Actualizar” del DVD, pero cuando nos presenta ya toda la información de la actualización he modificado la ubicación del cargador de arranque, que era, como es usual en esta distribución en “/”, y la he configurado en MBR. Si lo dejo en “/” no funciona. Hasta ahora es la única solución que he encontrado. Buscando por internet, no he encontrado solución alguna.

      Así que por el momento cuando pierda el menú de Grub de Leap porque se actualice en otra distribución: DVD de instalación, opción “Actualizar” y configurar el menú de arranque en MBR.

      La verdad que esta cuestión me tiene un tanto mosqueado. Suerte y saludos flamencos,

      Eliminar
    2. Gracias por la respuesta, habrá que seguir probando, y buscando la solución, llevo una temporada con esto y es curioso. incluso cambié boot de MBR a la partición extendida con Gparted, en fin, todo se andará
      Salu2

      Eliminar
  6. Muchas gracias por tu tiempo en preparar estos dos tutoriales.
    Ya está todo instalado y funcionando, por ahora...
    Un saludo y gracias de nuevo.

    ResponderEliminar
    Respuestas
    1. Gracias a ti por comentar y saludos flamencos,

      Eliminar
    2. Pues me ha surgido un problemilla...
      A ver si alguien por aquí tiene alguna idea de como solucionarlo.
      El problema es con el sonido. Mi equipo tiene la tarjeta de sonido integrada en la placa y además una independiente con mas calidad de sonido.
      Ya me ha pasado otras veces al instalar una nueva versión de openSUSE, que no se oía nada de sonido a través de los auriculares (no tengo instalados ningunos altavoces).
      Me dirijo a "preferencias del sistema" y en "multimedia" le doy preferencia a la tarjeta de sonido que quiero y problema resuelto... a medias.
      Consigo que se escuche la música perfectamente desde Amarok, pero los vídeos (o cualquier otro sonido) que intento reproducir desde Firefox no se escuchan nada.
      En "YAST > Hardware > Sonido" consigo también poner la tarjeta de sonido como "0", pero todo sigue igual.
      En este mismo lugar a través de la opción "otros" desactivo "Pulseaudio", y se escuchan los sonidos desde Firefox, pero no la música de Amarok...
      ¿Alguna idea de que puedo hacer?
      Muchas gracias.

      Eliminar
    3. Veamos si alguna de estas dos opciones te soluciona el problema:

      1) Pica botón derecho sobre el icono de altavoz que está en el panel, en la bandeja de sistema. En “Volumen del sonido” tienes cuatro pestañas. En “Configuración” puede que tengas la solución; quizás aquí tengas que seleccionar la misma opción que en “Preferencias del sistema>Multimedia”. En dispositivos de salida en “Port” tienes un desplegable, en mi sistema puedo seleccionar “Line Out” o “Headphones”. En tu caso puede ser distinto -no lo sé-.

      2) Algunos problemas de sonido se solucionan cambiando el motor de sonido, esto lo puedes consultar en el siguiente enlace:

      http://diversidadyunpocodetodo.blogspot.com.es/2013/12/kde-motor-sonido-phonon-vlc-gstreamer-musica.html

      Suerte y saludos flamencos,

      Eliminar
    4. Hola Benjamin.
      Ante todo, muchísimas gracias por tu tiempo y por tu consejo. He probado lo que me decías pero no hay manera, o puedo oír los sonidos que me llegan desde Firefox o los de Amarok-VLC, pero no los dos a la vez.
      Al final, he recordado una recomendación que me hicieron hace algún tiempo, y aunque me parece muy "bruta", la he llevado a cabo y me ha funcionado, por ahora...
      Lo que he hecho ha sido acceder a la BIOS y desactivar la tarjeta de sonido integrada (AC97), y como te digo, ahora mismo me suenan bien las dos fuentes.
      ¡Espero no haber roto nada!
      Muchas gracias de nuevo por tu tiempo y tus artículos.
      Un saludo.

      Eliminar
    5. Yo no diría que es una solución “bruta”, porque al parecer te es efectiva. Gracias por comentar aquí cómo has resulto finalmente la papeleta, segura que le es útil a alguien. Yo me lo apunto, nunca se sabe.

      Saludos flamencos,

      Eliminar
  7. Hola de nuevo.
    A ver si alguien tiene alguna idea para solucionar el problema que me ha surgido.
    Tengo una impresora HP envy 4500, la tengo hace poco tiempo y la verdad es que prácticamente no la he usado. El caso es que en openSUSE 13.2 me funcionaba la impresión y el escaner. Fue fácil instalar el software de HP y para escanear me funcionaba Skanlite desde el primer momento.
    Pero al instalar openSUSE leap 42.1 han empezado los problemas. Instalar el software de HP (hplip) me ha costado sudores, y no consigo que funcione Skanlite, no reconoce ningún escaner. Tambíen lo he intentado con Simple-scan y lo mismo.
    ¿A alguien se le ocurre alguna idea de que puedo tocar?
    Muchas gracias.

    ResponderEliminar
    Respuestas
    1. Hola buenas.

      Creo recordar que me costó mucho poder escanear con mi hp aun teniendo skanlite, y creo también recordar que lo pude solucionar instalando xsane.

      ¿Has mirado si tienes instalado hplip-sane?

      Un saludo.

      Un saludo

      Eliminar
  8. Hola JCarlos.
    Muchas gracias por la respuesta.
    Pues si, tengo ya instalado hplip-sane y xsane, pero no me funciona, ni Skanlite, ni SimpleScan, ni Xsane. Todos ellos me dicen que no tengo ningún escaner conectado...
    Así que ni idea.
    Muchas gracias de nuevo.

    ResponderEliminar
    Respuestas
    1. Hola.

      Y dices que tienes instalado el software verdad? El HPLIP Status Service? El resto de servicios te funcionan, cómo la impresión normal?

      Lo que a mí me sucede es que he de configurar la ip de la impresora en estática ya que en dinámica cambia y el software no la reconoce, claro, si este fuera tu problema no podrías siquiera imprimir, tendrías que configurar la impresora otra vez.

      Yo probaría a desinstalarla desde el manager, volver a instalar, si continua sin funcionar desinstalar skanlite y xsane, volver a instalarlos y reiniciar.

      Un saluso

      Eliminar
  9. Este proceso es practicamente lo mismo que te he escrito arriba:


    Initially on a new install of 13.1 the scan function was not in the HP toolbox as an option for my HP c8280 all in one scanner (12.1 and prior never had any issues)
    1) installed HPLIP (HP-toolbox) from Yast
    2) give the user lp permission
    3) run hp-toolbox
    4) add > advanced > manual > enter IP address of printer
    5) Yast > scanner > it should find the HP c7280 but you have to click edit and I selected one of the listed drivers for my model
    6) go back into HP-toolbox and select menu : Configure > Preferences > Commands Tab > add "skanlite" to the line for scan (without quotes)

    sacado de aquí: https://forums.opensuse.org/showthread.php/492182-13-1-HPLIP-multifunction-and-scanner

    Espero que te sirva.

    ResponderEliminar
    Respuestas
    1. Muchas gracias amigo una vez más por las aportaciones.

      Saludos flamencos,

      Eliminar
    2. Hola de nuevo.
      Ante todo, muchas gracias por la respuesta a JCarlos y a Benjamin.
      A la pregunta que me haces te respondo que si, la impresora imprime pero no escanea.
      Antes de leer tu respuesta ya había instalado y desinstalado HPlip mas de una vez, pero no Skanlite ni Xsane. Esta vez si que lo he hecho y ¡me funciona todo!
      Tampoco sé si he tocado en algo que no había tocado antes, o antes lo hice mal y ahora "no tan mal".
      Una duda: la versión de HPlip instalable desde YAST es la 3.14.6, sin embargo, desde su página web te descargas la 3.15.11. Había instalado una vez una, y otra vez la otra, pero con las dos tenía problemas. Esta vez he instalado la 3.15.11, no sé si esto originará algún problema.
      Al menos, por ahora, todo funciona.
      Así que muchísimas gracias a los dos por la ayuda.
      Un saludo por bulerías.

      Eliminar
    3. Me alegro si he podido ser de ayuda.

      Saludos a tí y a Benja.

      Eliminar
  10. hola buenas noches, tengo un problema en mi sistema opensuse leap, hace unos dias me salian unas actualizaciones de sistema, pero cuando queria instalarlas me daban error, logre instalarlas desde el gestor de actualizaciones de yast, se instalaron de manera corecta, hace unos dias busque de nuevo yast para instalar una impresora, al buscarlo no lo encontre y lo he buscado por todos lados en mi sistema y no logro encontrarlo, simplemente no aparece, alguien sabe como reinstalarlo o repararlo.?? se los agradeceria mucho.

    ResponderEliminar
    Respuestas
    1. Es treméndamente raro esto que te ha sucedido. Quizás simplemente volviendo a instalar Yast por la consola se solucione la papeleta, ya sabes:

      # su (contraseña)
      # zypper install yast2

      Suerte y saludos flamencos,

      Eliminar
  11. Hola,
    Muy agradecido por tus guias/manuales/tutoriales son una maravilla.
    Los he seguido para instalar y probar por primera vez openSUSE.
    Tengo un pequeño problemilla, o me da la sensación de que me falta algún repositorio, no lo se.
    El caso es que intento buscar por ejemplo filezilla y no me aparece.
    Estoy con el escritorio de plasma, he intentado seguir los pasos para tenerlo a la última pero no he sido capaz de conseguirlo, me daba muchos errores de dependencia y no me quedo claro. Así que volví al origen.
    De nuevo muchas gracias por estas fantásticas ayudas que nos ofreces.
    Un saludo

    ResponderEliminar
    Respuestas
    1. Sí, la actualización de Plasma lleva un tiempo que es demasiado problemática, así que mejor quedarse en la versión de los repositorios oficiales. En cuanto a Filezilla, igual que otras aplicaciones que no están en los repositorios oficiales, puede que este en los repositorios de la comunidad (openSUSE Build Service). Y así es con Filezilla. Lo puedes localizar buscándolo en:

      https://software.opensuse.org/search

      Sobre como instalar estas aplicaciones y sobre los repositorios de la comunidad te recomiendo que primero leas el siguiente artículo:

      http://diversidadyunpocodetodo.blogspot.com.es/2012/11/opensuse-build-service-one-click-install-repositorios-paquetes.html

      Saludos flamencos,

      Eliminar
  12. Hola, esta página es genial. Gracias a tus consejos en https://diversidadyunpocodetodo.blogspot.com/2015/02/instalar-google-earth-6-panoramio-opensuse-132.html , pude ver las fotografías de panoramio. Pero en este caso es otro el problema que tengo:
    Resulta que instalo OpenSuse 42.1 con Plasma 5 de entorno, todo fino. Un día decido ver una peli que me recomendaron pero el sonido estaba bajo. Decido tratar de subir el sonido, primero busco verla en VLC con 125% pero no es suficiente, reviso la configuración del sonido en el módulo de la bandeja del sistema y en el SystemSetting de KDE y veo que todo está al máximo (tanto la analógica como la digital). Entro en consola y tecleo "alsamixer" reviso que todas las salidas de sonido estén al máximo. Finalmente, me introduzco en el Yast2 - y aquí comenzó todo problema y el suspirar - para configurar las dos tarjetas que aparecen allí y luego de aceptar la configuración automática despareció el sonido. En la bandeja el ícono aparece con "X" y no muestra ninguna tarjeta, igualmente en las preferencias del sistema ya no hay tarjeta de sonido, lo que es peor tecleo en consola "alsamixer" y ella responde: "cannot open mixer: No existe el fichero o el directorio". Ayúdenme con eso, por favor.

    ResponderEliminar
    Respuestas
    1. Antes de que llegaras a YaST, te hubiera sugerido que cambiaras el motor de sonido sobre lo cual te puede servir el siguiente artículo:

      https://diversidadyunpocodetodo.blogspot.com.es/2013/12/kde-motor-sonido-phonon-vlc-gstreamer-musica.html

      En Plasma 5 el motor se cambia -después de instalar el paquete correspondiente- en “Audio y vídeo” en la pestaña “Motor”

      Sobre el problema que te ha surgido finalmente no sabría que decirte. Pero es posible que si instalas el otro motor de sonido como se indica en el enlace recuperes los controladores.

      Suerte y saludos flamencos,

      Nota: Si encontrará otra posible solución te la pondré aquí.

      Eliminar
    2. 1) Resultó que el sonido vuelve al teclear en Konsole "pulseaudio --start". El problema, es que en cada reinicio tengo que aplicar el comando para que se active el sonido.
      2) Trasteando por allá y por acullá en Saint Google, en otro sitio leí que era problemas con kmix, hice lo que dice esa página pero no sirvió (aquí queda por si acaso https://archeando.wordpress.com/2013/09/05/kmix-no-detecta-pulseaudio-al-arrancar/ ). Pensé pero si me sale dos íconos de audio en la bandeja: el primero es de kmix, el segundo aparece sin nada al iniciar y se activa y aparece lo que debe aparecer al usar el comando del punto (1), pues nada, a eliminar kmix a ver que pasa. Susto mayúsculo, inmediatamente se desconfiguró el segundo monitor. Cierro sesión, no sin antes encomendarme a Dios, y al entrar todo finoline, jajaja, fue solo el susto .
      3) En mi trasteo conseguí una página que hacen ciertas recomendaciones para subir el nivel de sonido de manera realmente significativa: http://hatteras-blog.blogspot.com/2014/01/permitir-que-el-volumen-exceda-del-100.html
      Para finalizar tengo audio, pero únicamente si comandeo "pulseaudio --start". Será de esa manera por los momentos.

      Eliminar
  13. Buenos días Benjamín.

    Vuelta al post para comentar que ayer después de intentar mis propios pasos no tenía manera de hacer funcionar Skanlite, los pasos que seguí para que funcionara fueron muy sencillos y fueron los siguientes:

    - Dentro de Yast, ir a Escáner, Edit, dejar el driver por defecto, next y ok.

    En mi caso no hizo falta reiniciar.

    Un saludo amigo.

    ResponderEliminar
    Respuestas
    1. Imagino que has disfrutado de unas merecidas vacaciones. Gracias por tu aportación amigo, como siempre es muy útil.
      Saludos flamencos,

      Eliminar
    2. Amigo mis "vacaciones" empiezan cuando acaban las del resto de la gente ;-)
      Espero ser claro en mis explicaciones porque la verdad es que lo mio no es explicar.

      Un saludo

      Eliminar
    3. Amigo, no es que no hayas sido claro -tus aportaciones son siempre muy nítidas- es que yo he presupuesto lo que he creído obvio -me he pasado de listo-. Yo siempre que puede tomo vacaciones fuera de la época usual, lo prefiero así: viajar es más barato y hay menos aglomeraciones por todos lados.

      Saludos flamencos,

      Eliminar
  14. Benjamín creo que ha habido una confusión, me refería a ser claro cuando explico cómo soluciono mis problemas con Opensuse no con mis vacaciones jajaj.
    Pero estás en lo cierto, es la mejor temporada para viajar. Quitando que oscurece pronto y que en la montaña puedes encontrar tiempo desapacible, lo que sea menos esta calor.

    Un saludo amigo.

    ResponderEliminar
    Respuestas
    1. JaJaJaJa, ¡Tremendo!. Por cierto, hoy nos estamos cociendo en Murcia. Que tengas una buena semana y saludos flamencos,

      Eliminar
    2. Lo mismo en Alicante, y rodeados de horribles incendios.

      Saludos e igualmente en la medida de lo posible...

      Eliminar

Publicar un comentario